CVE-2026-52709: Video Gallery Block (WordPress plugin) · Cross-site Scripting
Affects Video Gallery Block (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.7.0 when convenient.
Data as of 29 Oct 2026, 14:52 UTC
Thin evidence
One scorer or none| CNA (Patchstack) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 1.7.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Video Gallery Block (WordPress plugin) to 1.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Video Gallery Blockvideo-gallery-block | Affected
| Fixed in
|
AI-suggested
Upgrade the bPlugins Video Gallery Block plugin to version 1.7.0 or later, where this vulnerability has been fixed. No other specific mitigation actions are indicated by the vendor advisory.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Video Gallery Block video-gallery-block allows Stored XSS.This issue affects Video Gallery Block: from n/a through 1.6.0.