CVE-2026-53474: migration-planner · SQL Injection
Affects migration-plannerSource CVE Database V5
Not known to be exploited · CVSS 9.6 Critical : upgrade to 0.13.5 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.13.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade migration-planner to 0.13.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubmigration-plannerpkg:github/migration-plannerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for migration-planner that fixes this vulnerability in versions 0.13.5 and later. Users should upgrade to version 0.13.5 or newer to remediate this issue. Red Hat's advisory states that no currently supported Red Hat products are affected, so no action is required for Red Hat customers. For other users of migration-planner, applying the official patch or update is the recommended mitigation.
Description
CVE-2026-53474 is a critical SQL Injection vulnerability in migration-planner that allows a remote authenticated attacker to execute malicious SQL by uploading a specially crafted RVTools .xlsx file. This flaw enables arbitrary file reading on the system, potentially exposing sensitive information such as Kubernetes service account tokens and credentials, which could lead to full compromise of the SaaS environment. The vulnerability affects versions prior to 0.13.5. Red Hat has assessed that this vulnerability does not impact any currently supported Red Hat products. A patch is available to address this issue.