CVE-2026-53556: dataease SQLBot · SQL Injection
Affects dataease SQLBotSource CVE Database V5
Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.9.0 when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade SQLBot and dataease/SQLBot to 1.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| dataeaseSQLBot | Affected
| Fixed in
|
GitHubdataease/SQLBotpkg:github/dataease/SQLBotOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SQLBot to version 1.9.0 or later, where this SQL injection vulnerability is fixed. The vendor advisory confirms that the issue is resolved in this version. Until upgrading, restrict access to the previewData API endpoint to trusted users only and review PostgreSQL authentication configurations to avoid accepting invalid credentials with superuser privileges.
Description
CVE-2026-53556 is an SQL injection vulnerability in dataease SQLBot prior to version 1.9.0. The issue occurs in the POST /api/v1/datasource/previewData endpoint, where the client-controlled table_name parameter is incorporated into SQL queries without proper safe identifier handling. This allows an authenticated user to execute read-only SELECT operations that can invoke PostgreSQL functions to read filesystem contents. In default configurations, the internal PostgreSQL connection accepts invalid credentials and runs with superuser privileges, potentially exposing sensitive files such as /etc/hosts and /etc/passwd. The vulnerability is fixed in version 1.9.0.
References
- github.com/dataease/SQLBot/security/advisories/GHSA-vwjq-5h4h-x8g5 (opens in a new tab)
- github.com/dataease/SQLBot/pull/1156 (opens in a new tab)
- github.com/dataease/SQLBot/commit/76b5176b0e394740fd07c0d1769c0c792e8cb3b4 (opens in a new tab)
- github.com/dataease/SQLBot/releases/tag/v1.9.0 (opens in a new tab)