Skip to main content
VulnerabilityPublished

CVE-2026-53723: guzzle-services · Improper Input Validation

Affects guzzle-servicesSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.8 Medium : upgrade to 1.5.4 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.4, 1.5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade guzzle-services to 1.5.4; guzzle/guzzle-services to 1.5.3.

Affected software

ProductAffectedFixed in
guzzleguzzle-servicesAffected
  • <1.5.4
Fixed in
  • 1.5.4
Packagistguzzle/guzzle-servicespkg:composer/guzzle/guzzle-servicesOther threatsAffected
  • <1.5.3
Fixed in
  • 1.5.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in guzzle-services version 1.5.3 and later, which safely handles embedded CDATA terminators to prevent injection. Users should upgrade to version 1.5.3 or newer. As a workaround before patching, constrain attacker-controlled XML element values with strict enums, patterns, or custom filters that exclude the CDATA terminator sequence ']]>', or avoid serializing untrusted input into XML element text parameters with location: xml. Review service descriptions for parameters using location: xml to identify affected areas. XML attributes are not affected by this issue. No action is required if only response deserialization is used without subsequent request serialization of untrusted data.

Description

Guzzle Services versions prior to 1.5.3 improperly serialize scalar XML element values containing the CDATA terminator ']]>', causing early CDATA section closure and injection of attacker-controlled XML elements in outgoing requests. This vulnerability affects applications that serialize untrusted input into XML element text parameters with location: xml, potentially allowing alteration of operation semantics or injection of conflicting elements. The issue does not affect response parsing directly and is fixed in version 1.5.3 by safely handling embedded CDATA terminators.

References

Community reviews

Loading reviews…