Skip to main content
VulnerabilityPublished

CVE-2026-53726: parse-server · Insecure Direct Object Reference

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.9.1-alpha.6 or 8.6.80 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9.1-alpha.6, 8.6.80
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.9.1-alpha.6 or 8.6.80; parse-community/parse-server to 8.6.80.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.9.1-alpha.6
Fixed in
  • 9.9.1-alpha.6
parse-communityparse-serverAffected
  • <8.6.80
Fixed in
  • 8.6.80
GitHubparse-community/parse-serverpkg:github/parse-community/parse-serverOther threatsAffected
  • <8.6.80
  • =9.9.1-alpha.6
Fixed in
  • 8.6.80

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in parse-server versions 8.6.80 and 9.9.1-alpha.6. Users should upgrade to these or later versions to remediate the issue. Patch status is not explicitly stated as official-fix or temporary-fix in the advisory, but the vendor has released fixed versions. Until upgrading, applications relying on protectedFields or ACLs for Relation confidentiality remain vulnerable. No other vendor-provided mitigations or workarounds are indicated.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.80 and 9.9.1-alpha.6, a relation query using the $relatedTo operator could read the membership of a Relation field even when that field was hidden from the requesting client by protectedFields, and even when the object owning the relation was not readable by the client under its ACL or class-level permissions. The request requires only the public API credentials that Parse clients normally carry — no user session, master key, or Cloud Code is needed. As a result, an unauthenticated client who knows or obtains the owning object's objectId could enumerate the objects linked through a protected relation, or combine the operator with an objectId constraint to use it as a membership oracle — confirming whether a specific object is linked to a private parent. This affects applications that rely on protectedFields or object ACLs to keep Relation membership confidential, such as private group memberships, block lists, or account-to-resource associations. This issue has been patched in versions 8.6.80 and 9.9.1-alpha.6.

References

Community reviews

Loading reviews…