Skip to main content
VulnerabilityPublished

CVE-2026-53754: unclecode crawl4ai · Server-Side Request Forgery (SSRF)

Affects unclecode crawl4aiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.8.8 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade crawl4ai and unclecode/crawl4ai to 0.8.8.

Affected software

ProductAffectedFixed in
unclecodecrawl4aiAffected
  • <0.8.8
Fixed in
  • 0.8.8
GitHubunclecode/crawl4aipkg:github/unclecode/crawl4aiOther threatsAffected
  • <0.8.8
Fixed in
  • 0.8.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade crawl4ai to version 0.8.8 or later, where this SSRF vulnerability is fixed. Since the Docker API is unauthenticated by default, enabling authentication (jwt_enabled: true) can also reduce risk. Patch status is confirmed fixed in 0.8.8.

Description

Crawl4AI is an open-source LLM friendly web crawler & scraper. Prior to 0.8.8, the Docker API server's SSRF protection (validate_webhook_url / validate_url_destination in deploy/docker/utils.py) used an explicit IPv4/IPv6 CIDR blocklist that missed several address families. An attacker could reach internal services and cloud metadata endpoints (e.g. 169.254.169.254) despite the filter by encoding an internal IPv4 address inside an IPv6 transition form, or by using the IPv6 unspecified address. Because the Docker API is unauthenticated by default (jwt_enabled: false), no credentials are required. This vulnerability is fixed in 0.8.8.

References

Community reviews

Loading reviews…