Skip to main content
VulnerabilityPublished Updated

CVE-2026-54081: veraPDF-parser · Improperly Controlled Sequential Memory Allocation

Affects veraPDF-parserSource CVE Database V5

0

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.31.23 or 1.30.2 when convenient.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.31.23, 1.30.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade veraPDF-parser and verapdf/veraPDF-parser to 1.31.23 or 1.30.2.

Affected software

ProductAffectedFixed in
veraPDFveraPDF-parserAffected
  • >=1.31.1 <1.31.23
Fixed in
  • 1.31.23
veraPDFveraPDF-parserAffected
  • <1.30.2
Fixed in
  • 1.30.2
GitHubverapdf/veraPDF-parserpkg:github/verapdf/veraPDF-parserOther threatsAffected
  • <1.30.2
  • <1.31.23
Fixed in
  • 1.30.2
  • 1.31.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade veraPDF-parser to version 1.30.2 or 1.31.23 or later where this vulnerability is fixed. No other mitigation or workaround is indicated in the available data.

Description

veraPDF-parser versions prior to 1.30.2 and 1.31.23 contain a denial-of-service vulnerability due to improperly controlled sequential memory allocation. A crafted Type 1 font can trigger unbounded PostScript array allocation, zero-increment loops, or recursive dictionary lookups, exhausting memory, CPU, or stack resources. This issue is fixed in versions 1.30.2 and 1.31.23.

References

Community reviews

Loading reviews…