Skip to main content
VulnerabilityPublished Updated

CVE-2026-109619: Php5 · request-owned internal state can survive after its backing memory has been freed

Affects php5Source GCVE Database

0
Authoritative record:CVE-2026-109619· Critical 9.2

Exploited in the wild · KEV due 29 Oct 2026 · fixed in 5.5.9+dfsg-1ubuntu4.29+esm18 : patch php5 now.

Data as of 27 Oct 2026, 08:13 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 5.5.9+dfsg-1ubuntu4.29+esm18, 7.0.33-0ubuntu0.16.04.16+esm22, 7.2.24-0ubuntu0.18.04.17+esm14 +5
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by PHP Group

    , 9 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 6 minutes after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 8 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10php8.5pkg:deb/ubuntu/php8.5?arch=source&distro=stonkingOther threatsAffected
  • <8.5.9-0ubuntu2.1
Fixed in
  • 8.5.9-0ubuntu2.1
Ubuntu 26.04 LTSphp8.5pkg:deb/ubuntu/php8.5?arch=source&distro=resoluteOther threatsAffected
  • <8.5.4-0ubuntu1.5
Fixed in
  • 8.5.4-0ubuntu1.5
Ubuntu 24.04 LTSphp8.3pkg:deb/ubuntu/php8.3?arch=source&distro=nobleOther threatsAffected
  • <8.3.6-0ubuntu0.24.04.13
Fixed in
  • 8.3.6-0ubuntu0.24.04.13
Ubuntu 22.04 LTSphp8.1pkg:deb/ubuntu/php8.1?arch=source&distro=jammyOther threatsAffected
  • <8.1.2-1ubuntu2.28
Fixed in
  • 8.1.2-1ubuntu2.28
Ubuntu Pro 20.04 LTSphp7.4pkg:deb/ubuntu/php7.4?arch=source&distro=esm-infra/focalOther threatsAffected
  • <7.4.3-4ubuntu2.29+esm5
Fixed in
  • 7.4.3-4ubuntu2.29+esm5
Ubuntu Pro 18.04 LTSphp7.2pkg:deb/ubuntu/php7.2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <7.2.24-0ubuntu0.18.04.17+esm14
Fixed in
  • 7.2.24-0ubuntu0.18.04.17+esm14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches are available and should be applied promptly. Updating PHP packages to the fixed versions listed in the Ubuntu security notices USN-8948-1 and USN-8948-2 will remediate this vulnerability. Standard system updates on supported Ubuntu releases will include these fixes. No additional mitigations are required beyond applying the official updates.

Description

CVE-2026-109619 is a high-severity vulnerability in PHP where internal request state can persist after its backing memory has been freed. This stale state may be used by a later request handled by the same worker before it is properly reinitialized, potentially allowing remote code execution. The issue affects multiple PHP versions across various Ubuntu releases. Official patches are available and should be applied to mitigate the risk.

References

Community reviews

Loading reviews…