Skip to main content
VulnerabilityPublished Updated

CVE-2026-109618: php5, php7.0, php7.2, php7.4 vulnerabilities

Affects php5Source GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-109618· Critical 9.2

Exploited in the wild · KEV due 29 Oct 2026 · public exploit available (Exploit-DB) · fixed in 5.5.9+dfsg-1ubuntu4.29+esm18 : patch php5 now.

Data as of 27 Oct 2026, 06:42 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 5.5.9+dfsg-1ubuntu4.29+esm18, 7.0.33-0ubuntu0.16.04.16+esm22, 7.2.24-0ubuntu0.18.04.17+esm14 +1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  3. Observed by OffSeq Mirage: evidence found.

    81 honeypot hits, first 43 hours after disclosure

Timeline

  1. CVE ID reserved

    by PHP Group

    , 9 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. First Exploit-DB entry (opens in a new tab)

    PHP2Shell (CVE-2026-109618) - PHP core versions after v5.4 - RCE

    , 1 day after disclosure

  4. First seen by OffSeq Mirage

    from 9 attacker networks; activity in Portugal, Netherlands, Poland, United States and 12 more

    , 43 hours after disclosure

  5. In Threat Radar

    record ingested

    , 5 days after disclosure

  6. , 5 days after disclosure

  7. , 6 days after disclosure

  8. KEV remediation due

    US federal deadline

    , 8 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTSphp7.4pkg:deb/ubuntu/php7.4?arch=source&distro=esm-infra/focalOther threatsAffected
  • <7.4.3-4ubuntu2.29+esm5
Fixed in
  • 7.4.3-4ubuntu2.29+esm5
Ubuntu Pro 18.04 LTSphp7.2pkg:deb/ubuntu/php7.2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <7.2.24-0ubuntu0.18.04.17+esm14
Fixed in
  • 7.2.24-0ubuntu0.18.04.17+esm14
Ubuntu Pro 16.04 LTSphp7.0pkg:deb/ubuntu/php7.0?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <7.0.33-0ubuntu0.16.04.16+esm22
Fixed in
  • 7.0.33-0ubuntu0.16.04.16+esm22
Ubuntu Pro 14.04 LTSphp5pkg:deb/ubuntu/php5?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • <5.5.9+dfsg-1ubuntu4.29+esm18
Fixed in
  • 5.5.9+dfsg-1ubuntu4.29+esm18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

USN-8948-1 fixed vulnerabilities in Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, Ubuntu 26.04 LTS and Ubuntu 26.10. This provides the corrosponding updates in Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. Original advisory details: It was discovered that PHP incorrectly handled out-of-memory conditions while processing requests. A remote attacker could use this issue to execute arbitrary code. (CVE-2026-109618) It was discovered that PHP incorrectly managed internal request state across worker reuse. A remote attacker could use this issue to execute arbitrary code. (CVE-2026-109619)

References

Community reviews

Loading reviews…