Skip to main content
VulnerabilityPublished

CVE-2026-5418: appsmithorg appsmith · Server-Side Request Forgery

Affects appsmithorg appsmithSource CVE Database V5

0
Compare

Public exploit available · CVSS 6.9 Medium · fixed in 1.99 : patch appsmithorg appsmith as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.99
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
appsmithorgappsmithAffected
  • 1.0 – 1.97
98 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:appsmith:appsmith:*:*:*:*:*:*:*:*

AI-suggested

Upgrade the affected appsmith component to version 1.99 or later, as this version contains the official fix for the SSRF vulnerability. No other mitigation is required once the upgrade is applied.

Description

A vulnerability was identified in appsmithorg appsmith up to 1.97. Impacted is the function computeDisallowedHosts of the file app/server/appsmith-interfaces/src/main/java/com/appsmith/util/WebClientUtils.java of the component Dashboard. Such manipulation leads to server-side request forgery. The attack may be launched remotely. The exploit is publicly available and might be used. Upgrading to version 1.99 is recommended to address this issue. The affected component should be upgraded. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

References

Community reviews

Loading reviews…