CVE-2026-54181: Laravel-Backpack CRUD · Cross-site Scripting
Affects Laravel-Backpack CRUDSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 7.0.38 or 6.8.14 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.0.38, 6.8.14
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade CRUD and laravel-backpack/CRUD to 7.0.38 or 6.8.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Laravel-BackpackCRUD | Affected
| Fixed in
|
| Laravel-BackpackCRUD | Affected
| Fixed in
|
GitHublaravel-backpack/CRUDpkg:github/laravel-backpack/CRUDOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Laravel-Backpack CRUD to version 6.8.14 or later in the 6.x series, or 7.0.38 or later in the 7.x series, where the escaping logic has been corrected. No other mitigations are specified or required once patched.
Description
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.38, src/resources/views/crud/columns/color.blade.php inverts the escaped and raw rendering branches controlled by $column['escaped'], which defaults to true, causing $column['text'] to be rendered unescaped by default. An attacker who can store an unsanitized value in a color column can execute script in the browser of a user who views the CRUD list, including an administrator, with access to the victim's session-backed application capabilities. Exploitation requires write access to the stored color value and a victim viewing the list. This issue is fixed in versions 6.8.14 and 7.0.38.
References
- github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-mmg4-322v-6jvc (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/pull/5992 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/pull/5994 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/commit/608652b1020ba274781f222d2959d7780a559a08 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/commit/76c3a6e50e3fbd6d5f633208da5b04acb8322969 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/releases/tag/6.8.14 (opens in a new tab)
- github.com/Laravel-Backpack/CRUD/releases/tag/7.0.38 (opens in a new tab)