Skip to main content
VulnerabilityPublished

CVE-2026-54232: vllm · Uncontrolled Search Path Element

Affects vllmSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.22.1 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.22.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade vllm to 0.22.1.

Affected software

ProductAffectedFixed in
vllm-projectvllmAffected
  • <0.22.1
Fixed in
  • 0.22.1
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • <0.22.1
Fixed in
  • 0.22.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade vLLM to version 0.22.1 or later, where this vulnerability is fixed. Until then, avoid building Docker images with versions prior to 0.22.1 or modify the Dockerfile and package installation process to prevent dependency confusion attacks. Patch status is confirmed fixed in 0.22.1.

Description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.

References

Community reviews

Loading reviews…