Skip to main content
VulnerabilityPublished Updated

CVE-2026-54297: lostisland faraday · Uncontrolled Recursion

Affects lostisland faradaySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.14.3 or 1.10.6 soon.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.14.3, 1.10.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade lostisland faraday to 2.14.3 or 1.10.6.

Affected software

ProductAffectedFixed in
lostislandfaradayAffected
  • >=2.0.0.alpha.pre.1 <2.14.3
Fixed in
  • 2.14.3
lostislandfaradayAffected
  • >=1.0.0 <1.10.6
Fixed in
  • 1.10.6
RubyGemsfaradaypkg:gem/faradayOther threatsAffected
  • <1.10.6
  • <2.14.3
Fixed in
  • 1.10.6
  • 2.14.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Faraday versions 1.10.6 and 2.14.3. Users should upgrade to these or later versions to remediate the vulnerability. Red Hat currently states that no alternative mitigation is available that meets their criteria for ease of use and applicability. Therefore, upgrading to a fixed version is the recommended action.

Description

Faraday is an HTTP client library abstraction layer that provides a common interface over many adapters. From 1.0.0 until 1.10.6 and 2.14.3, Faraday::NestedParamsEncoder, the default nested query parameter encoder/decoder in Faraday, decodes nested query strings without enforcing a maximum nesting depth. A crafted query string causes Faraday to build a deeply nested Ruby Hash structure. The internal dehash routine then recursively walks this attacker-controlled structure without a depth limit. At sufficient depth, Ruby raises an uncaught SystemStackError (stack level too deep), crashing the calling thread or worker. This can lead to denial of service in applications that pass attacker-controlled query strings to Faraday's nested query parsing or URL-building paths. This vulnerability is fixed in 1.10.6 and 2.14.3.

References

Community reviews

Loading reviews…