Skip to main content
VulnerabilityPublished

CVE-2026-54304: n8n · Information Exposure

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 2.26.1 : patch n8n soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.26.1, 2.25.7, 1.123.55
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.26.1, 2.25.7 or 1.123.55.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.26.0 <2.26.1
Fixed in
  • 2.26.1
n8n-ion8nAffected
  • >=2.0.0-rc.0 <2.25.7
Fixed in
  • 2.25.7
n8n-ion8nAffected
  • <1.123.55
Fixed in
  • 1.123.55
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threatsAffected
  • <1.123.55
  • <2.25.7
  • <2.26.1
Fixed in
  • 1.123.55
  • 2.25.7
  • 2.26.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in n8n versions 1.123.55, 2.25.7, and 2.26.1. Users should upgrade to at least these versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.1, an authenticated user with permission to create or modify workflows and access to a SecurityScorecard credential with limited allowed domains could configure the SecurityScorecard node's report download operation to target an attacker-controlled URL. The node attached the SecurityScorecard API token to the outbound request, causing the credential to be sent to the attacker-controlled host bypassing credential configured limitations and exfiltrating. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.1.

References

Community reviews

Loading reviews…