Skip to main content
VulnerabilityPublished

CVE-2025-61917: n8n · Resource Exposure

Affects n8nSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 1.114.3 soon.

Data as of 26 Oct 2026, 12:29 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.114.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n to 1.114.3.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=1.65.0 <1.114.3
Fixed in
  • 1.114.3
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threatsAffected
  • =1.65.0
  • =1.114.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade all n8n instances to version 1.114.3 or later immediately to apply the patch that replaces unsafe buffer allocation with safe, zero-initialized buffers.
  2. Conduct a thorough audit of workflows and tasks to identify any that handle sensitive data, ensuring that secrets and tokens are stored and transmitted securely using n8n's credential management features.
  3. Restrict access to the n8n environment to trusted users and networks, minimizing the risk of low-privilege attackers exploiting the vulnerability.
  4. Implement runtime monitoring and logging to detect unusual access patterns or data exfiltration attempts related to workflow executions.
  5. If upgrading immediately is not possible, consider isolating n8n instances in segmented network zones and applying strict access controls to reduce exposure.
  6. Review and update incident response plans to include scenarios involving potential data leakage from workflow automation platforms.
  7. Educate developers and administrators about secure coding and configuration practices within n8n to prevent introduction of similar vulnerabilities.

Description

CVE-2025-61917 is a high-severity vulnerability in the n8n workflow automation platform versions 1.65.0 through before 1.114.3. It arises from the unsafe use of Buffer.allocUnsafe() and Buffer.allocUnsafeSlow() in the task runner, which can lead to allocation of uninitialized memory buffers. These buffers may contain residual sensitive data such as secrets, tokens, or data from prior tasks within the same Node.js process, resulting in potential information disclosure.

References

Community reviews

Loading reviews…