Skip to main content
VulnerabilityPublished

CVE-2026-54453: OpenCATS · Injection

Affects OpenCATSSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High : upgrade to 0.10.0 soon.

Data as of 28 Oct 2026, 22:12 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenCATS and opencats/OpenCATS to 0.10.0.

Affected software

ProductAffectedFixed in
opencatsOpenCATSAffected
  • <0.10.0
Fixed in
  • 0.10.0
GitHubopencats/OpenCATSpkg:github/opencats/OpenCATSOther threatsAffected
  • <0.10.0
Fixed in
  • 0.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenCATS to version 0.10.0 or later, where this vulnerability is fixed. Ensure that config.php is not writable by the web server process if upgrading is not immediately possible. Restrict administrator access to the Settings module and Professional License configuration to trusted users only.

Description

OpenCATS versions prior to 0.10.0 contain a vulnerability in the Professional License configuration feature that allows an authenticated administrator with Settings module access to inject arbitrary PHP code. This occurs because license key input is unsafely incorporated into a PHP define() statement in config.php, which is writable. Exploitation can lead to persistent arbitrary PHP execution with web server privileges, enabling data exposure, modification, or deletion, and potential further compromise. The issue is fixed in version 0.10.0.

References

Community reviews

Loading reviews…