CVE-2026-54455: OpenCATS · Improper Input Validation
Affects OpenCATSSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 0.10.0 soon.
Data as of 28 Oct 2026, 22:12 UTC
- Patch
- Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade OpenCATS and opencats/OpenCATS to 0.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opencatsOpenCATS | Affected
| Fixed in
|
GitHubopencats/OpenCATSpkg:github/opencats/OpenCATSOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenCATS to version 0.10.0 or later, where this vulnerability is fixed. No other mitigations are specified or required according to the vendor advisory.
Description
OpenCATS versions prior to 0.10.0 contain an improper input validation vulnerability in the activity DataGrid date filtering functionality. Authenticated users can manipulate the 'period', 'startDate', and 'endDate' parameters to alter SQL queries without proper escaping, potentially accessing sensitive database information. This issue is fixed in version 0.10.0.