CVE-2026-54507: givanz Vvveb · Server-Side Request Forgery (SSRF)
Affects givanz VvvebSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.0.8.5 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.8.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade Vvveb and givanz/Vvveb to 1.0.8.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| givanzVvveb | Affected
| Fixed in
|
GitHubgivanz/Vvvebpkg:github/givanz/VvvebOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to version 1.0.8.5 or later, where this vulnerability is fixed. No additional mitigation is required as the fix addresses the root cause by properly validating resolved addresses.
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in givanz Vvveb prior to version 1.0.8.5. An authenticated admin user with editor permissions can exploit the oEmbedProxy() handler by supplying a crafted URL parameter that bypasses hostname validation and causes the server to make HTTP/HTTPS requests to internal or reserved IP addresses. This can lead to disclosure of internal service responses or cloud instance metadata and credentials. The vulnerability is fixed in version 1.0.8.5.