Skip to main content
CVE-2026-34753VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat AI Inference 3.4.4 (spyre)

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-34753· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium : upgrade Red Hat vllm to 0.19.0 when convenient.

Data as of 1 Nov 2026, 08:20 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade vllm to 0.19.0.

Affected software

ProductAffectedFixed in
vllm-projectvllmAffected
  • >=0.16.0 <0.19.0
Fixed in
  • 0.19.0
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • >=0.16.0 <0.19.0
Fixed in
  • 0.19.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Currently, there is no available fix or mitigation that meets Red Hat Product Security criteria for this vulnerability. Customers with a Red Hat Technical Account Manager (TAM) can consult directly for tailored guidance. Applying network-level controls to limit server access to internal services may reduce risk until an official fix is released.

Description

A server-side request forgery (SSRF) vulnerability exists in the vLLM batch runner component of Red Hat AI Inference 3.4.4 (spyre). An attacker who can control batch input JSON may exploit this flaw to force the server to make arbitrary HTTP/HTTPS requests, potentially accessing internal services such as cloud metadata endpoints or internal APIs. This could lead to information disclosure or further compromise of the host system. Currently, no effective mitigation or fix meeting Red Hat's criteria is available.

References

Community reviews

Loading reviews…