Red Hat Security Advisory: Red Hat AI Inference Model Optimization Tools 3.4.5 (cuda)
Affects Red HatSource GCVE Database
Not known to be exploited · CVSS 8.0 High · fixed in Red Hat package updates : patch Red Hat transformers soon.
Data as of 1 Nov 2026, 08:20 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.5.0
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| huggingfacehuggingface/transformers | Affected
| Fixed in– |
PyPItransformerspkg:pypi/transformersOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
No mitigation currently meets Red Hat Product Security criteria for ease of use, applicability, or stability. Users should avoid loading untrusted LightGlue models until a fix is available. Red Hat has not released a patch yet. Customers are advised to monitor Red Hat advisories and coordinate with Red Hat support or their Technical Account Manager for updates and guidance.
Description
CVE-2026-5241 is a high-severity vulnerability in python-transformers used by Red Hat AI Inference Server and Red Hat OpenShift AI. It allows arbitrary code execution when loading a malicious LightGlue model because the trust_remote_code security parameter can be overridden by untrusted configuration data. This flaw can lead to credential theft, unauthorized access, or backdoor deployment. The vulnerability affects all python-transformers versions before 5.5.0, with no current mitigation meeting Red Hat's criteria. Red Hat has not released a fix for this issue yet.
References
- access.redhat.com/errata/RHSA-2026:70996 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-5241 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-54058 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-54060 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-55379 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-55380 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59197 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59199 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59200 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59204 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-59205 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-64847 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- redhat.com/en/products/ai/inference-server (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_70996.json (opens in a new tab)