Skip to main content
VulnerabilityPublished

CVE-2026-54549: pipeboard-co meta-ads-mcp · Server-Side Request Forgery (SSRF)

Affects pipeboard-co meta-ads-mcpSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.3 High : upgrade to 1.0.115 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.115
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade meta-ads-mcp and pipeboard-co/meta-ads-mcp to 1.0.115.

Affected software

ProductAffectedFixed in
pipeboard-cometa-ads-mcpAffected
  • <1.0.115
Fixed in
  • 1.0.115
GitHubpipeboard-co/meta-ads-mcppkg:github/pipeboard-co/meta-ads-mcpOther threatsAffected
  • <1.0.115
Fixed in
  • 1.0.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to meta-ads-mcp version 1.0.115 or later, where this SSRF vulnerability is fixed. No additional mitigation steps are indicated as the fix addresses the root cause by validating and restricting the URLs used in image downloads.

Description

CVE-2026-54549 is a server-side request forgery (SSRF) vulnerability in the meta-ads-mcp product by pipeboard-co. The flaw exists in versions prior to 1.0.115 in the upload_ad_image tool, which improperly handles attacker-controlled URLs without validating scheme, host, or resolved IP address. This allows an attacker to make the server perform unauthorized HTTP requests to internal or private network resources. The vulnerability is fixed in version 1.0.115.

References

Community reviews

Loading reviews…