CVE-2026-63184: christianhelle refitter · Untrusted Functionality Inclusion
Affects christianhelle refitterSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 2.1.1 soon.
Data as of 30 Oct 2026, 22:22 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.1 |
|---|
- Patch
- Available – fixed in 2.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade refitter and christianhelle/refitter to 2.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| christianhellerefitter | Affected
| Fixed in
|
GitHubchristianhelle/refitterpkg:github/christianhelle/refitterOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Refitter to version 2.1.1 or later, where the unsafe $ref resolution defaults have been fixed. No other mitigation is required as the issue is resolved in this official fix.
Description
Refitter versions prior to 2.1.1 contain a vulnerability where the tool uses unsafe defaults for JSON schema $ref resolution when processing attacker-controlled OpenAPI descriptions. This allows remote HTTP(S) references to be fetched and inlined, and local file paths including directory traversal to be resolved and included, leading to server-side request forgery, remote file inclusion, and local file disclosure. The issue does not lead to code execution due to runtime URL setting and string escaping. The vulnerability is fixed in version 2.1.1.
References
- github.com/christianhelle/refitter/security/advisories/GHSA-x6w4-f264-3vvr (opens in a new tab)
- github.com/christianhelle/refitter/pull/1173 (opens in a new tab)
- github.com/christianhelle/refitter/commit/6ad20a3803561225100b0a4bb6b12f947d23db7b (opens in a new tab)
- github.com/christianhelle/refitter/releases/tag/2.1.1 (opens in a new tab)
- github.com/user-attachments/files/29395269/reproduce.sh (opens in a new tab)
- github.com/user-attachments/files/29395271/maintainer-report.txt (opens in a new tab)
- github.com/user-attachments/files/29395272/advisory.md (opens in a new tab)
- github.com/user-attachments/files/29395283/reproduce.sh (opens in a new tab)
- github.com/user-attachments/files/29395284/maintainer-report.txt (opens in a new tab)
- github.com/user-attachments/files/29395285/advisory.md (opens in a new tab)
- github.com/user-attachments/files/29395286/listener.py (opens in a new tab)
- github.com/user-attachments/files/29395288/make_spec.py (opens in a new tab)