CVE-2026-54577: MidnightBSD mport · Improper Input Validation
Affects MidnightBSD mportSource CVE Database V5
Not known to be exploited · CVSS 2.0 Low : upgrade to 2.7.8 when convenient.
Data as of 1 Nov 2026, 11:03 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.8
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade mport and midnightbsd/mport to 2.7.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MidnightBSDmport | Affected
| Fixed in
|
GitHubmidnightbsd/mportpkg:github/midnightbsd/mportOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade mport to version 2.7.8 or later, where the issue is fixed by proper resetting of parsing state before argument processing. No other mitigation is required as the fix addresses the root cause.
Description
mport is the MidnightBSD Package Manager. Prior to 2.7.8, the audit command in mport/mport.c computed option-adjusted local_argv and local_argc values but passed the original argument entry to audit_package(). When an operator or automation used an option such as -r before a package name, stale optind state and the unadjusted argument could cause mport to audit the option token instead of the requested package, producing a false-negative or useless result that could leave a vulnerable package unidentified. The corrected parsing resets optind and optreset before using the adjusted local arguments. This issue is fixed in version 2.7.8.
References
- github.com/MidnightBSD/mport/security/advisories/GHSA-h3m9-vj4v-c35h (opens in a new tab)
- github.com/MidnightBSD/mport/pull/149 (opens in a new tab)
- github.com/MidnightBSD/mport/commit/b897240dc8181c53fbee231e77f88657c1edb9a0 (opens in a new tab)
- github.com/MidnightBSD/mport/releases/tag/2.7.8 (opens in a new tab)