CVE-2026-54627: HappySeaFox sail · Heap-based Buffer Overflow
Affects HappySeaFox sailSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.0.0 as a priority.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade sail and happyseafox/sail to 1.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HappySeaFoxsail | Affected
| Fixed in
|
GitHubhappyseafox/sailpkg:github/happyseafox/sailOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to HappySeaFox sail version 1.0.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Patch status is confirmed fixed in 1.0.0.
Description
A heap-based buffer overflow vulnerability exists in HappySeaFox sail versions before 1.0.0. The flaw occurs in the PSD image loading code where a mismatch between pixel format and file depth causes out-of-bounds writes when loading crafted PSD files. This can lead to memory corruption, crashes, or potential code execution. The issue is fixed in version 1.0.0.