Skip to main content
VulnerabilityPublished Updated

CVE-2026-54692: HappySeaFox sail · Incorrect Calculation of Buffer Size

Affects HappySeaFox sailSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 1.0.0 soon.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade sail and happyseafox/sail to 1.0.0.

Affected software

ProductAffectedFixed in
HappySeaFoxsailAffected
  • <1.0.0
Fixed in
  • 1.0.0
GitHubhappyseafox/sailpkg:github/happyseafox/sailOther threatsAffected
  • <1.0.0
Fixed in
  • 1.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in HappySeaFox sail version 1.0.0. Users and developers should upgrade to version 1.0.0 or later to remediate this issue. No other mitigation is indicated by the vendor advisory.

Description

A heap buffer overflow vulnerability exists in HappySeaFox sail library versions prior to 1.0.0 in the function sail_codec_load_frame_v8_xbm(). The issue arises from incorrect buffer size calculation when decoding certain X10 static short files, leading to a forward heap overwrite that scales with image height. This can corrupt process state, cause crashes, and potentially allow code execution. The vulnerability is fixed in version 1.0.0.

References

Community reviews

Loading reviews…