CVE-2026-54650: bablilayoub openhole · Path Traversal
Affects bablilayoub openholeSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 0.1.2 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade bablilayoub openhole to 0.1.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bablilayoubopenhole | Affected
| Fixed in
|
AI-suggested
A fix is available in bablilayoub openhole version 0.1.2. Users should upgrade to version 0.1.2 or later to remediate this vulnerability. No other official remediation guidance is provided. Patch status is not explicitly stated but the description confirms the issue is fixed in 0.1.2.
Description
CVE-2026-54650 is a path traversal vulnerability in bablilayoub openhole versions 0.1.1 and earlier. The openhole-server component improperly forwards the URL path, allowing encoded dot segments and separators to bypass restrictions and access tunneled local services. This flaw allows an attacker to expose localhost services to the internet. The issue is fixed in version 0.1.2.