CVE-2026-54664: acacode swagger-typescript-api · Injection
Affects acacode swagger-typescript-apiSource CVE Database V5
Not known to be exploited · CVSS 8.3 High : upgrade to 13.12.2 soon.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 13.12.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade acacode swagger-typescript-api to 13.12.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| acacodeswagger-typescript-api | Affected
| Fixed in
|
npmswagger-typescript-apipkg:npm/swagger-typescript-apiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to swagger-typescript-api version 13.12.2 or later, where this vulnerability is fixed by properly escaping enum values before rendering. No other mitigation is indicated or required.
Description
CVE-2026-54664 is a high severity code injection vulnerability in the swagger-typescript-api tool prior to version 13.12.2. The vulnerability arises because enum values from an OpenAPI specification are passed without proper escaping to template rendering code, allowing attacker-controlled input to inject executable code into generated TypeScript modules. This code executes when the generated module is imported. The issue is fixed in version 13.12.2.
References
- github.com/acacode/swagger-typescript-api/security/advisories/GHSA-5f94-x226-ccpm (opens in a new tab)
- github.com/acacode/swagger-typescript-api/pull/1779 (opens in a new tab)
- github.com/acacode/swagger-typescript-api/commit/306d59acb8ffbb00f953f807b97234b21f51d9de (opens in a new tab)
- github.com/acacode/swagger-typescript-api/releases/tag/v13.12.2 (opens in a new tab)