Skip to main content
VulnerabilityPublished

CVE-2026-54734: prebid-server-java · Server-Side Request Forgery (SSRF)

Affects prebid-server-javaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 3.43.0 as a priority.

Data as of 1 Nov 2026, 11:03 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.43.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade prebid-server-java and org.prebid/prebid-server-java to 3.43.0.

Affected software

ProductAffectedFixed in
prebidprebid-server-javaAffected
  • <3.43.0
Fixed in
  • 3.43.0
Mavenorg.prebid/prebid-server-javapkg:maven/org.prebid/prebid-server-javaOther threatsAffected
  • <3.43.0
Fixed in
  • 3.43.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade prebid-server-java to version 3.43.0 or later, where this SSRF vulnerability is fixed. No other mitigation is indicated or required according to the available data.

Description

CVE-2026-54734 is a critical Server-Side Request Forgery (SSRF) vulnerability in prebid-server-java versions prior to 3.43.0. Certain bidder adapters improperly interpolate user-supplied parameters into outbound request URLs without proper validation, allowing attackers to cause the server to send HTTP requests to unintended destinations. This can lead to unauthorized access to internal network services or sensitive server endpoints. The issue is fixed in version 3.43.0.

References

Community reviews

Loading reviews…