Skip to main content
VulnerabilityPublished Updated

CVE-2026-5485: Amazon Athena ODBC driver · OS Command Injection

Affects Amazon Athena ODBC driverSource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 2.0.5.1 soon.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0.5.1, 2.0.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Amazon Athena ODBC driver to 2.0.5.1; amazon/AmazonAthenaODBC to 2.0.5.

Affected software

ProductAffectedFixed in
AmazonAmazon Athena ODBC driverAffected
  • <2.0.5.1
Fixed in
  • 2.0.5.1
Amazonamazon/AmazonAthenaODBCpkg:rpm/amazon/AmazonAthenaODBCOther threatsAffected
  • <2.0.5
Fixed in
  • 2.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade the Amazon Athena ODBC driver to version 2.0.5.1 or later, where this vulnerability is fixed. No other mitigations are specified by the vendor advisory. Applying this official fix fully remediates the vulnerability.

Description

CVE-2026-5485 is an OS command injection vulnerability in the browser-based authentication component of the Amazon Athena ODBC driver on Linux. It affects versions before 2.0.5.1 and allows a local user to execute arbitrary code by supplying specially crafted connection parameters. The vulnerability has a high severity with a CVSS score of 7.8. Users should upgrade to version 2.0.5.1 or later to remediate the issue.

References

Community reviews

Loading reviews…