Skip to main content
VulnerabilityPublished

CVE-2026-54900: Integer Overflow or Wraparound in ohler55 oj

Affects ojSource GCVE Database

0

Not known to be exploited : upgrade to 3.17.2 when convenient.

Data as of 26 Oct 2026, 13:47 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.17.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade oj to 3.17.2.

Affected software

ProductAffectedFixed in
RubyGemsojpkg:gem/ojOther threatsAffected
  • <3.17.2
Fixed in
  • 3.17.2
Ubuntu 14.04 LTSruby-ojpkg:deb/ubuntu/ruby-oj?arch=source&distro=trustyOther threatsAffected
  • 2.0.10-1 – 2.5.3-1
4 affected builds
Fixed in–
Ubuntu 16.04 LTSruby-ojpkg:deb/ubuntu/ruby-oj?arch=source&distro=xenialOther threatsAffected
  • 2.12.10-3 – 2.12.10-4build1
4 affected builds
Fixed in–
Ubuntu 18.04 LTSruby-ojpkg:deb/ubuntu/ruby-oj?arch=source&distro=bionicOther threatsAffected
  • =2.17.4-1
  • =3.4.0-1
  • =3.4.0-1build1
Fixed in–
Ubuntu 20.04 LTSruby-ojpkg:deb/ubuntu/ruby-oj?arch=source&distro=focalOther threatsAffected
  • 3.8.1-1 – 3.10.1-1build1
5 affected builds
Fixed in–
Ubuntu 22.04 LTSruby-ojpkg:deb/ubuntu/ruby-oj?arch=source&distro=jammyOther threatsAffected
  • 3.11.0-1 – 3.13.9-1build1
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Oj version 3.17.2. Users should upgrade to version 3.17.2 or later to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2026-54900 is an integer overflow vulnerability in the Oj Ruby gem used for JSON parsing and object marshalling. Versions prior to 3.17.2 are affected when a JSON object key is exactly 65,535 bytes long, causing heap corruption and process crashes due to a negative size passed to memcpy. The issue is fixed in version 3.17.2.

References

Community reviews

Loading reviews…