Skip to main content
VulnerabilityPublished

CVE-2026-55237: Significant-Gravitas AutoGPT · Improper Neutralization of Alternate XSS Syntax

Affects Significant-Gravitas AutoGPTSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 0.6.62 soon.

Data as of 1 Nov 2026, 08:20 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.62
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade AutoGPT and significant-gravitas/AutoGPT to 0.6.62.

Affected software

ProductAffectedFixed in
Significant-GravitasAutoGPTAffected
  • <0.6.62
Fixed in
  • 0.6.62
GitHubsignificant-gravitas/AutoGPTpkg:github/significant-gravitas/AutoGPTOther threatsAffected
  • <0.6.62
Fixed in
  • 0.6.62

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade AutoGPT to version 0.6.62 or later, where this vulnerability is patched. No other official remediation or temporary fixes are documented. Until patched, avoid clicking on untrusted links that include the 'next' parameter in the URL on the signup page.

Description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Versions prior to 0.6.62 have a DOM-based Cross-Site Scripting (XSS) vulnerability in AutoGPT's signup page. The application improperly trusts a URL parameter (`next`), which is passed to `router.push`. An attacker can craft a malicious link that, when opened by an authenticated user, performs a client-side redirect and executes arbitrary JavaScript in the context of their browser. This could lead to credential theft, internal network pivoting, and unauthorized actions performed on behalf of the victim. Version 0.6.62 patches the issue.

References

Community reviews

Loading reviews…