Skip to main content
VulnerabilityPublished

CVE-2026-55423: langflow · Insufficient Session Expiration

Affects langflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.7.0 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.7.0
CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade langflow and langflow-ai/langflow to 1.7.0.

Affected software

ProductAffectedFixed in
langflow-ailangflowAffected
  • <1.7.0
Fixed in
  • 1.7.0
GitHublangflow-ai/langflowpkg:github/langflow-ai/langflowOther threatsAffected
  • <1.7.0
Fixed in
  • 1.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade langflow to version 1.7.0 or later, where the session expiration issue is fixed. No other mitigations are indicated. Patch status is not explicitly confirmed in the vendor advisory, but the fix is stated to be in 1.7.0.

Description

Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to 1.7.0, the logout button does not clear the session. The previous user stays logged in unless another user explicitly logs in. This vulnerability is fixed in 1.7.0.

References

Community reviews

Loading reviews…