Skip to main content
VulnerabilityPublished

CVE-2026-55486: intranda goobi-viewer-core · Cross-site Scripting

Affects intranda goobi-viewer-coreSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 26.05 as a priority.

Data as of 26 Oct 2026, 12:42 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.05
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade goobi-viewer-core and intranda/goobi-viewer-core to 26.05.

Affected software

ProductAffectedFixed in
intrandagoobi-viewer-coreAffected
  • >=25.08 <26.05
Fixed in
  • 26.05
GitHubintranda/goobi-viewer-corepkg:github/intranda/goobi-viewer-coreOther threatsAffected
  • >=25.08 <26.05
Fixed in
  • 26.05

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in intranda goobi-viewer-core version 26.05 that fixes this vulnerability. Users should upgrade to version 26.05 or later to remediate the issue. No other mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-55486 is a critical cross-site scripting (XSS) vulnerability in the intranda goobi-viewer-core web application. Versions from 25.08 up to but not including 26.05 are affected. The flaw arises because the IIIF Auth 2.0 endpoints auth/login and auth/token accept an origin query parameter without proper validation. This parameter is then embedded unsafely into the Content-Security-Policy header and an HTML response body, enabling reflected XSS attacks. The vulnerability has been patched in version 26.05.

References

Community reviews

Loading reviews…