Skip to main content
VulnerabilityPublished

CVE-2026-55522: MervinPraison PraisonAI · Code Injection

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.8 High : upgrade to 4.6.58 soon.

Data as of 3 Nov 2026, 10:58 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.58, 1.6.58
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade PraisonAI to 4.6.58; praisonaiagents to 1.6.58.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • >=3.9.26 <4.6.58
Fixed in
  • 4.6.58
MervinPraisonpraisonaiagentsAffected
  • >=0.12.12 <1.6.58
Fixed in
  • 1.6.58
PyPIpraisonaipkg:pypi/praisonaiOther threatsAffected
  • >=3.9.26 <=4.6.57
Fixed in–
PyPIpraisonaiagentspkg:pypi/praisonaiagentsOther threatsAffected
  • >=0.12.12 <=1.6.57
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PraisonAI version 4.6.58 and praisonaiagents version 1.6.58. Users should upgrade to these versions or later to remediate this vulnerability. No other mitigations are indicated in the provided data.

Description

PraisonAI versions 3.9.26 through 4.6.57 and praisonaiagents versions 0.12.12 through 1.6.57 contain a code injection vulnerability in the workflow "include" feature. The vulnerability arises because the _execute_include() function imports and executes an included recipe's tools.py file without enforcing security gates or using a safe loader. This allows arbitrary Python code execution if an attacker can cause a workflow to include an untrusted local recipe. The issue is fixed in versions 4.6.58 and 1.6.58 respectively.

References

Community reviews

Loading reviews…