Skip to main content
VulnerabilityPublished

CVE-2026-57142: MervinPraison PraisonAI · OS Command Injection

Affects MervinPraison PraisonAISource CVE Database V5

0

Not known to be exploited · CVSS 7.8 High : upgrade to 4.6.61 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.6.61
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.61.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • >=4.5.87 <4.6.61
Fixed in
  • 4.6.61
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • >=4.5.87 <4.6.61
Fixed in
  • 4.6.61

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.6.61 or later where this vulnerability is patched. No other mitigation is indicated by the vendor advisory.

Description

CVE-2026-57142 is a high-severity OS command injection vulnerability in MervinPraison PraisonAI versions 4.5.87 up to but not including 4.6.61. The vulnerability arises because the recipe execution policy that blocks dangerous tools only checks tools declared in TEMPLATE.yaml, but the actual workflow execution loads tools from workflow.yaml, allowing untrusted recipes to self-approve critical shell tools without explicit permission. This flaw enables unauthorized execution of shell commands. The issue has been fixed in version 4.6.61.

References

Community reviews

Loading reviews…