CVE-2026-56838: MervinPraison PraisonAI · OS Command Injection
Affects MervinPraison PraisonAISource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 4.6.59 soon.
Data as of 26 Oct 2026, 17:30 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.59
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade PraisonAI and mervinpraison/PraisonAI to 4.6.59.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MervinPraisonPraisonAI | Affected
| Fixed in
|
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade PraisonAI to version 4.6.59 or later, where the dangerous tool policy check is enforced consistently across all execution paths, including recipe.run_stream(). No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-56838 is an OS command injection vulnerability in MervinPraison's PraisonAI affecting versions from 4.5.87 up to but not including 4.6.59. The issue arises because the streaming execution path recipe.run_stream() bypasses the dangerous tool policy check that is enforced in the normal recipe.run() path. This allows execution of commands that should be denied unless explicitly allowed, potentially leading to high impact on confidentiality, integrity, and availability. The vulnerability has been patched in version 4.6.59.