Skip to main content
VulnerabilityPublished

CVE-2026-55602: chimurai http-proxy-middleware · Improper Input Validation

Affects chimurai http-proxy-middlewareSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium · fixed in 4.1.0 : update chimurai http-proxy-middleware when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.0, 3.0.6, 2.0.10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade chimurai http-proxy-middleware to 4.1.0, 3.0.6 or 2.0.10.

Affected software

ProductAffectedFixed in
chimuraihttp-proxy-middlewareAffected
  • >=4.0.0 <4.1.0
Fixed in
  • 4.1.0
chimuraihttp-proxy-middlewareAffected
  • >=3.0.0 <3.0.6
Fixed in
  • 3.0.6
chimuraihttp-proxy-middlewareAffected
  • >=0.16.0 <2.0.10
Fixed in
  • 2.0.10
npmhttp-proxy-middlewarepkg:npm/http-proxy-middlewareOther threatsAffected
  • <2.0.10
  • <3.0.6
  • <4.1.0
Fixed in
  • 2.0.10
  • 3.0.6
  • 4.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade http-proxy-middleware to version 2.0.10, 3.0.6, or 4.1.0 or later where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Patch status is confirmed fixed in these versions.

Description

http-proxy-middleware is node.js http-proxy middleware. From 0.16.0 until 2.0.10, 3.0.6, and 4.1.0, http-proxy-middleware documents router proxy-table entries as host, path, or host+path selectors, but the host+path implementation uses unanchored substring matching on attacker-controlled request metadata. As a result, a crafted Host header that is only a superstring match for a configured host+path key can still route a request to an unintended backend. This vulnerability is fixed in 2.0.10, 3.0.6, and 4.1.0.

References

Community reviews

Loading reviews…