Skip to main content
VulnerabilityPublished

CVE-2026-55691: StarCitizenWiki mediawiki-extensions-EmbedVideo · Cross-site Scripting

Affects StarCitizenWiki mediawiki-extensions-EmbedVideoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 4.1.0 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mediawiki-extensions-EmbedVideo and starcitizenwiki/mediawiki-extensions-EmbedVideo to 4.1.0.

Affected software

ProductAffectedFixed in
StarCitizenWikimediawiki-extensions-EmbedVideoAffected
  • <4.1.0
Fixed in
  • 4.1.0
GitHubstarcitizenwiki/mediawiki-extensions-EmbedVideopkg:github/starcitizenwiki/mediawiki-extensions-EmbedVideoOther threatsAffected
  • <4.1.0
Fixed in
  • 4.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the EmbedVideo extension to version 4.1.0 or later, where the vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Users should ensure that only trusted users have edit permissions to reduce risk.

Description

CVE-2026-55691 is a high-severity cross-site scripting (XSS) vulnerability in the EmbedVideo extension for MediaWiki used by StarCitizenWiki. The vulnerability exists in versions prior to 4.1.0, where user-supplied input for the class attribute is improperly sanitized, allowing injection of arbitrary HTML or JavaScript. This enables an attacker with edit permissions to inject malicious scripts that execute when other users view the affected wiki pages. The issue is fixed in version 4.1.0.

References

Community reviews

Loading reviews…