Skip to main content
VulnerabilityPublished

CVE-2026-117645: phoenixframework phoenix_html · Cross-site Scripting

Affects phoenixframework phoenix_htmlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.4.0 or 3.3.5 when convenient.

Data as of 30 Oct 2026, 20:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (EEF)CVSS 4.05.3
Patch
Available – fixed in 4.4.0, 3.3.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade phoenixframework phoenix_html to 4.4.0 or 3.3.5.

Affected software

ProductAffectedFixed in
phoenixframeworkphoenix_htmlAffected
  • >=4.0.0 <4.4.0
Fixed in
  • 4.4.0
phoenixframeworkphoenix_htmlAffected
  • >=1.0.0 <3.3.5
Fixed in
  • 3.3.5
phoenix_htmlphoenixframework/phoenix_htmlAffected
  • ≥ 6ad3a1d7960891a468d54636054a98e11dfb5111, < d9e4e6b2d9be49e25fb6d6b4fdbb2008174f01a6
Fixed in–
Hexphoenix_htmlpkg:hex/phoenix_htmlOther threatsAffected
  • >=1.0.0 <3.3.5
  • >=4.0.0 <4.4.0
Fixed in
  • 3.3.5
  • 4.4.0

CPE configurations (1)

  • cpe:2.3:a:phoenixframework:phoenix_html:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions 3.3.5 and 4.4.0 of phoenix_html address this vulnerability. Users should upgrade to phoenix_html version 3.3.5 or later if using the 1.x to 3.x series, or to version 4.4.0 or later if using the 4.x series. No other mitigation or workaround is indicated. Applications should avoid building attribute keys from untrusted input or ensure input is properly sanitized before rendering.

Description

CVE-2026-117645 is a cross-site scripting (XSS) vulnerability in the phoenix_html library of the phoenixframework. It arises from improper neutralization of input during web page generation, specifically in the handling of attribute names in HTML rendering functions. The vulnerability affects phoenix_html versions from 1.0.0 up to but not including 3.3.5, and from 4.0.0 up to but not including 4.4.0. The issue allows an attacker controlling attribute names to inject malicious attributes and scripts into rendered HTML. This occurs because attribute names are not properly escaped, enabling injection via constructs like HEEx <tag {@attrs}>, content_tag/3, or direct calls. Fixed versions are 3.3.5 and 4.4.0.

References

Community reviews

Loading reviews…