Skip to main content
VulnerabilityPublished

CVE-2026-55847: allure-framework allure2 · Cross-site Scripting

Affects allure-framework allure2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 2.39.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.39.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade allure2 and allure-generator and allure-framework/allure2 to 2.39.0.

Affected software

ProductAffectedFixed in
allure-frameworkallure2Affected
  • <2.39.0
Fixed in
  • 2.39.0
io.qameta.allureallure-generatorAffected
  • <2.39.0
Fixed in
  • 2.39.0
GitHuballure-framework/allure2pkg:github/allure-framework/allure2Other threatsAffected
  • <2.39.0
Fixed in
  • 2.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Allure 2 version 2.39.0. Users should upgrade to version 2.39.0 or later to remediate this issue. No other mitigation actions are indicated by the vendor advisory.

Description

CVE-2026-55847 is a cross-site scripting (XSS) vulnerability in Allure 2, a multi-language test reporting tool. Versions prior to 2.39.0 improperly handle attacker-controlled input in the ansi.js helper by passing statusMessage and statusTrace values through AnsiToHtml without HTML escaping. This input is then wrapped in Handlebars SafeString, disabling template auto-escaping. Maliciously crafted JUnit XML failure messages and other plugin inputs can trigger this vulnerability. When a user views the affected status details, arbitrary JavaScript can execute in the report's origin, potentially exposing report data and compromising user sessions. The issue was fixed in version 2.39.0.

References

Community reviews

Loading reviews…