Skip to main content
VulnerabilityPublished Updated

CVE-2026-55846: allure-framework allure2 · Path Traversal

Affects allure-framework allure2Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.2 Medium : upgrade to 2.39.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.39.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade allure2 and io.qameta.allure/allure2 to 2.39.0.

Affected software

ProductAffectedFixed in
allure-frameworkallure2Affected
  • <2.39.0
Fixed in
  • 2.39.0
Mavenio.qameta.allure/allure2pkg:maven/io.qameta.allure/allure2Other threatsAffected
  • <2.39.0
Fixed in
  • 2.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Allure 2 to version 2.39.0 or later, where this path traversal vulnerability is fixed. Until upgraded, restrict access to the Allure HTTP server by avoiding use of the --host option to expose the server beyond localhost and limit access to trusted users only.

Description

CVE-2026-55846 is a path traversal vulnerability in Allure 2, a multi-language test reporting tool. Versions prior to 2.39.0 have an HTTP server that improperly handles pathname resolution, allowing an unauthenticated client to access arbitrary files readable by the Allure process. The server binds to localhost by default but can be exposed to other systems via the --host option. This vulnerability can lead to disclosure of sensitive information such as credentials, configuration files, source code, and CI/CD secrets. The issue is fixed in version 2.39.0.

References

Community reviews

Loading reviews…