CVE-2026-56670: Comfy-Org ComfyUI · Cross-site Scripting
Affects Comfy-Org ComfyUISource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 0.28.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.28.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Comfy-Org ComfyUI to 0.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Comfy-OrgComfyUI | Affected
| Fixed in
|
AI-suggested
Upgrade ComfyUI to version 0.28.0 or later, where the vulnerability has been fixed by properly handling SVG and related XML content types to prevent inline serving that leads to stored XSS. No other mitigation guidance is provided or required.
Description
CVE-2026-56670 is a high-severity cross-site scripting (XSS) vulnerability in Comfy-Org's ComfyUI prior to version 0.28.0. The issue arises because the /view endpoint served uploaded SVG files inline without properly handling dangerous content types like image/svg+xml, allowing stored XSS attacks. This vulnerability has been fixed in ComfyUI version 0.28.0.