Skip to main content
VulnerabilityPublished

CVE-2026-56673: Comfy-Org ComfyUI · Path Traversal

Affects Comfy-Org ComfyUISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 0.28.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.28.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Comfy-Org ComfyUI to 0.28.0.

Affected software

ProductAffectedFixed in
Comfy-OrgComfyUIAffected
  • <0.28.0
Fixed in
  • 0.28.0

AI-suggested

Upgrade ComfyUI to version 0.28.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

CVE-2026-56673 is a path traversal vulnerability in Comfy-Org's ComfyUI prior to version 0.28.0. The issue arises because certain functions join user-controlled filenames to a base directory without verifying containment, allowing unauthenticated attackers to read arbitrary files. This affects multiple nodes including LoadImage and related nodes. The vulnerability is fixed in version 0.28.0.

References

Community reviews

Loading reviews…