Skip to main content
VulnerabilityPublished

CVE-2026-57053: GNU libidn · Improper Validation of Specified Quantity in Input

Affects GNU libidnSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.0 Medium : upgrade to 1.44 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
4.0Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade GNU libidn to 1.44.

Affected software

ProductAffectedFixed in
GNUlibidnAffected
  • <1.44
Fixed in
  • 1.44

AI-suggested

If you cannot patch yet, avoid using vulnerable versions of GNU libidn prior to 1.44 in security-critical contexts. Consider upgrading to libidn2, which is not affected by this vulnerability.

Description

GNU libidn before 1.44 is prone to out-of-bounds reads of uninitialized memory in the ToUnicode APIs because of mishandling in idna_to_unicode_internal. The affected code is not present in libidn2.

References

Community reviews

Loading reviews…