CVE-2026-57200: asterisk · Path Traversal
Affects asteriskSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 23.4.1 : patch asterisk soon.
Data as of 27 Oct 2026, 21:43 UTC
- Patch
- Available – fixed in 23.4.1, 22.10.1, 21.12.3 +2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| asteriskasterisk | Affected
| Fixed in
|
| certified-asteriskcertified-asterisk | Affected
| Fixed in
|
GitHubasterisk/asteriskpkg:github/asterisk/asteriskOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading to Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1, or Certified Asterisk 22.8-cert3 or later. If upgrading is not immediately possible, ensure the Asterisk HTTP server is disabled or bound to localhost to reduce exposure. No other vendor advisory mitigation instructions are provided.
Description
CVE-2026-57200 is a path traversal vulnerability in Asterisk affecting versions prior to 20.20.1, 21.12.3, 22.10.1, 23.4.1, and Certified Asterisk 22.8-cert3. An authenticated attacker with read-only Asterisk REST Interface (ARI) credentials may exploit this to perform write operations via REST-over-WebSocket, leading to arbitrary module path loading and potential remote code execution. The vulnerability requires the Asterisk HTTP server to be enabled and reachable, which is disabled and bound to localhost by default. This issue has been fixed in the specified versions.
References
- github.com/asterisk/asterisk/security/advisories/GHSA-wcvv-g26m-wx5c (opens in a new tab)
- github.com/asterisk/asterisk/commit/051d29a0d35559e9165bab346de9422e25415533 (opens in a new tab)
- github.com/asterisk/asterisk/commit/205c301a0a0b0d013d4ebdf12856ebbc30405350 (opens in a new tab)
- github.com/asterisk/asterisk/commit/762b4c9c39b28fa5564112b0f484012298469a6c (opens in a new tab)
- github.com/asterisk/asterisk/commit/87641e9b2cd62c998c5283400ba77b61b5b07dd4 (opens in a new tab)
- github.com/asterisk/asterisk/commit/9d198a7d16ccba51507dfea6c1ecc511e89d698a (opens in a new tab)
- github.com/asterisk/asterisk/commit/c10cdbce072a708060cd38a89d6850808fe6bf46 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/20.20.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/21.12.3 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/22.10.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/23.4.1 (opens in a new tab)
- github.com/asterisk/asterisk/releases/tag/certified-22.8-cert3 (opens in a new tab)
- github.com/asterisk/asterisk/tree/24.0.0-pre1 (opens in a new tab)