Skip to main content
VulnerabilityPublished

CVE-2026-57192: asterisk · Out-of-bounds Read

Affects asteriskSource CVE Database V5

0

Not known to be exploited · CVSS 6.0 Medium · fixed in 23.4.1 : update asterisk when convenient.

Data as of 27 Oct 2026, 22:01 UTC

CVSS 4.0 base score
6.0Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.4.1, 22.10.1, 21.12.3 +3
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade asterisk to 23.4.1, 22.10.1, 21.12.3 or 20.20.1; certified-asterisk to 22.8-cert3 or 20.7-cert11.

Affected software

ProductAffectedFixed in
asteriskasteriskAffected
  • >=23.0.0-pre1 <23.4.1
Fixed in
  • 23.4.1
asteriskasteriskAffected
  • >=22.0.0-pre1 <22.10.1
Fixed in
  • 22.10.1
asteriskasteriskAffected
  • >=21.0.0-pre1 <21.12.3
Fixed in
  • 21.12.3
asteriskasteriskAffected
  • <20.20.1
Fixed in
  • 20.20.1
asteriskcertified-asteriskAffected
  • >=22.8-cert1-pre1 <22.8-cert3
Fixed in
  • 22.8-cert3
asteriskcertified-asteriskAffected
  • <20.7-cert11
Fixed in
  • 20.7-cert11

AI-suggested

Apply the official fixes by upgrading to Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1 or Certified Asterisk 20.7-cert11, 22.8-cert3. Ensure the codec_codec2 module is only loaded and Codec2 configured if necessary, and restrict SIP authentication to trusted users. Since patches are available, remediation should focus on timely upgrading to fixed versions.

Description

CVE-2026-57192 is a medium severity vulnerability in Asterisk's Codec2 decoder that allows an authenticated attacker to cause a heap buffer overflow via an out-of-bounds write. The flaw arises from a floor/ceil sample-count mismatch when the codec_codec2 module is loaded and Codec2 is configured on the endpoint. Exploitation requires SIP authentication and establishing a call using Codec2 with crafted audio packets. Fixed versions include Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1, and Certified Asterisk 20.7-cert11, 22.8-cert3.

References

Community reviews

Loading reviews…