Skip to main content
VulnerabilityPublished

CVE-2026-57191: asterisk · Classic Buffer Overflow

Affects asteriskSource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High · fixed in 23.4.1 : patch asterisk soon.

Data as of 27 Oct 2026, 21:58 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 23.4.1, 22.10.1, 21.12.3 +3
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade asterisk to 23.4.1, 22.10.1, 21.12.3 or 20.20.1; certified-asterisk to 22.8-cert3 or 20.7-cert11.

Affected software

ProductAffectedFixed in
asteriskasteriskAffected
  • >=23.0.0-pre1 <23.4.1
Fixed in
  • 23.4.1
asteriskasteriskAffected
  • >=22.0.0-pre1 <22.10.1
Fixed in
  • 22.10.1
asteriskasteriskAffected
  • >=21.0.0-pre1 <21.12.3
Fixed in
  • 21.12.3
asteriskasteriskAffected
  • <20.20.1
Fixed in
  • 20.20.1
asteriskcertified-asteriskAffected
  • >=22.8-cert1-pre1 <22.8-cert3
Fixed in
  • 22.8-cert3
asteriskcertified-asteriskAffected
  • <20.7-cert11
Fixed in
  • 20.7-cert11

AI-suggested

The vulnerability is fixed in Asterisk versions 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3. Users should upgrade to these fixed versions to remediate the issue. No other mitigation or workaround is indicated.

Description

CVE-2026-57191 is a high-severity classic stack buffer overflow vulnerability in Asterisk's res_pjsip_pubsub module. It occurs due to an unbounded sscanf call when parsing the MWI NOTIFY Message-Account field. An unauthenticated attacker can send a crafted packet to trigger this overflow, corrupting the transport and disabling all SIP functionality until the service is restarted. Fixed versions are available.

References

Community reviews

Loading reviews…