Skip to main content
VulnerabilityPublished

CVE-2026-57442: bitbonsai mcpvault · Path Traversal

Affects bitbonsai mcpvaultSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.11.5 when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.11.5
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mcpvault and bitbonsai/mcpvault to 0.11.5.

Affected software

ProductAffectedFixed in
bitbonsaimcpvaultAffected
  • <0.11.5
Fixed in
  • 0.11.5
GitHubbitbonsai/mcpvaultpkg:github/bitbonsai/mcpvaultOther threatsAffected
  • <0.11.5
Fixed in
  • 0.11.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to version 0.11.5 or later, where the path traversal vulnerability is fixed. No other mitigation is indicated or necessary as the issue is resolved in the official patch.

Description

CVE-2026-57442 is a path traversal vulnerability in bitbonsai mcpvault versions prior to 0.11.5. The issue arises because the PathFilter component uses root-anchored deny-list patterns that fail to restrict nested .git, .obsidian, and node_modules directories properly. This allows an attacker influencing AI-selected paths to access restricted metadata and files. The vulnerability is fixed in version 0.11.5.

References

Community reviews

Loading reviews…