Skip to main content
VulnerabilityPublished

CVE-2026-58141: langgenius dify · Server-Side Request Forgery (SSRF)

Affects langgenius difySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 1.15.0 soon.

Data as of 6 Nov 2026, 16:04 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.2
CNA (VulnCheck)CVSS 3.17.6
Patch
Available – fixed in 1.15.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade langgenius dify to 1.15.0.

Affected software

ProductAffectedFixed in
langgeniusdifyAffected
  • >=0.6.0 <1.15.0
Fixed in
  • 1.15.0
GitHubdifypkg:github/difyOther threatsAffected
  • >=0.6.0 <1.15.0
Fixed in
  • 1.15.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in dify version 1.15.0. Users should upgrade to version 1.15.0 or later to remediate this vulnerability. Since this is a cloud-hosted service, the vendor manages remediation for the cloud environment; verify with the vendor advisory for confirmation. No additional mitigation steps are indicated beyond applying the official fix.

Description

Dify versions before 1.15.0 contain a server-side request forgery (SSRF) vulnerability that allows authenticated console users to bypass SSRF protections and send arbitrary HTTP requests to internal services and cloud metadata endpoints. This is due to insufficient Squid proxy ACL configuration and lack of destination IP validation in the make_request() helper. The vulnerability enables access to internal components such as the sandbox, internal APIs, PostgreSQL, and on AWS, the instance metadata service, potentially exposing IAM credentials. The HTTP Request workflow node also allows modifying internal services via POST, PUT, and DELETE methods. A fix is available in version 1.15.0.

References

Community reviews

Loading reviews…