CVE-2026-58256: JeromeDevome GRR · Code Injection
Affects JeromeDevome GRRSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.5.0 as a priority.
Data as of 27 Oct 2026, 22:57 UTC
- Patch
- Available – fixed in 4.5.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade GRR and jeromedevome/GRR to 4.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JeromeDevomeGRR | Affected
| Fixed in
|
GitHubjeromedevome/GRRpkg:github/jeromedevome/GRROther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GRR to version 4.5.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.
Description
CVE-2026-58256 is a critical code injection vulnerability in JeromeDevome's GRR resource management application. Before version 4.5.0, an administrator could inject malicious PHP code via LDAP connector configuration parameters, leading to remote code execution. Exploitation requires the administrator to connect to an attacker-controlled LDAP server and submit crafted input. The vulnerability is fixed in version 4.5.0.